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Introduction

This document explains how to set up the BridgePort to act as an interface between a Data Highway Plus 
industrial network and an ALPHA sign network, as illustrated below:

Specifically, this document describes how to:

• connect the BridgePort to a Data Highway Plus PLC and to one or more ALPHA signs,

• use BridgePort Configuration Editor software to set up the BridgePort so that it interfaces between a Data 
Highway Plus PLC and an ALPHA sign network,

• use Gateway Messaging Software to program messages and variables into ALPHA signs, and

• use RSLogix 500 software to program a Data Highway Plus PLC to send data to and from the BridgePort 
and ALPHA signs.

Related documents

Document name Part number Description

Gateway Messaging Software User Manual 9703-7004
Describes how to use Adaptive’s Gateway Messaging Software to 
store messages in ALPHA signs.

Network Configurations 9708-8046 Explains how to network ALPHA signs.

How to connect ALPHA signs to Data Highway Plus
using the BridgePort

INFORMATION FLOW

NOTE: In the event of a communication failure, caused by any means, messages may not be displayed on a sign.

Data Highway Plus

industrial network (BridgePort)

Revision date: 1/19/01 Copyright © 2001 Adaptive Micro Systems, Inc. 9703-7006A
The distinctive Trade Dress of this product is a trademark claimed by Adaptive Micro Systems, Inc.
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BridgePort description

The BridgePort is an intelligent Data Highway Plus-to-serial communications interface unit. It allows data 
exchange between a Data Highway Plus host PLC and ALPHA signs equipped with the Gateway firmware option.

Item Name Description

A Port 3 (“passthrough port”)
Connect to a computer that is running the BridgePort Configuration Editor software and the 
Gateway Messaging Software.

B Status LED

Slow flash (on 2 seconds, off 2 seconds) = The BridgePort is in Firmware Download mode, 
waiting for the Configuration Editor software to download new firmware to it.

Medium flash (on 1 second, off 1 second) = The BridgePort is in Configuration mode, waiting for 
the Configuration Editor software to send new configuration data to it.

Fast flash (on 100 ms, off 100 ms) = The BridgePort is in Run mode, where it will receive Data 
Highway Plus messages and convert them to Modbus. This is automatically set: 1) on power 
up, or 2) after downloading the configuration. If configured, data will be passed through from 
the Passthrough port to the Modbus port.

(See “Troubleshooting BridgePort modes” on page 6 for methods to put the BridgePort into 
normal Run mode.

C Power LED
On = The BridgePort is receiving electrical power
Off = The BridgePort is not receiving electrical power

D Network 1 LED
On = Communication is being received from the Data Highway Plus host.
Off = No communication is being received from the Data Highway Plus host.

E Network 2 LED
On = Confirmation that communication is being received by the sign or other Modbus device.
Off = No confirmation that communication is being received by the sign or other Modbus device.

F Configuration button
Used only when downloading settings to the BridgePort. (See “BridgePort setup instructions” on 
page 4.) Use a pencil or similar pointed object to press this internal button.

G Port 2 Data output (RS485) to one or more ALPHA signs.

H Port 1 Data input from a Data Highway Plus host PLC.

I Power connector Connect to a DC power supply of 12 to 28 volts rated at 9 watts.

1
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BridgePort interconnection diagram

Item Part # Description

A 1088-9105A DB25-to-DB9 adapter (for DB25 computer COM port)

B 1188-0005

DB9-to-RJ45 Configuration Cable to Port 3

C 1088-8636 1 foot, 4-conductor RS485 cable (NOTE: If the Modular Network Adapter is inside the ALPHA sign, this cable is not necessary.)

D 4331-0602 Modular Network Adapter (NOTE: On some ALPHA signs, this adapter is inside the sign.)

E 1088-8000 RS485 cable

F
Call your
Adaptive 

distributor

Belden shielded cable (“Blue hose”) to Port 2

G —

Data Highway Plus cable to Port 1

(running BridgePort Configuration Editor software)
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Port 1

Port 2
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to power
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BridgePort setup instructions

1. Attach a computer to the BridgePort. (See “BridgePort interconnection diagram” on page 3.)

2. If not already installed, install the BridgePort Configuration Editor software on the computer that will be 
used to program the BridgePort.

Create the project file

3. Start the BridgePort Configuration Editor software. A screen similar to the following will appear.

NOTE: If the BridgePort Configuration Editor opens with an empty screen instead of with the “Data 
Highway Plus to Serial Port” window, you must create a new “project” file by selecting File > New.

4. Select Edit > Unit Configuration and make sure that Slave --> Master is selected, to set the BridgePort to slave 
mode.

5. Save the project by selecting File > Save. If prompted with a “Save As” window, provide an appropriate 
name and location.

Set up the COM port
6. Select Options > Set COM Port and choose the PC COM Port you will use to communicate with the 

BridgePort. (The default is COM 1.)

7. (Optional) Once a COM Port is selected, you may wish to save this setting by selecting Options > Default 
Options. If you do not do this, the COM port setting may revert to a former setting. The COM port setting 
is not part of the project, so saving the project will not save the COM port setting.
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Set up PLC communication (Port 1)
8. Select Edit > Net 1 Configuration to set up Port 1 on the BridgePort.

9. Select Save. You will be notified that the information was saved. Click Ok to exit this screen.

Set up ALPHA sign communication (Port 2)

10. Select Edit > Net 2 Configuration to set up Port 2 on the BridgePort so that it can communicate with ALPHA 
signs equipped with the Gateway firmware option.

11. Select Save. You will be notified that the information was saved. Click Ok to exit this screen.

Set up the “Passthrough” port (Port 3)
12.  Select Edit > Passthrough Configuration to set up Port 3.

13. Select Save. You will be notified that the information was saved. Click Ok to exit this screen.

14. Select File > Save to save all the project settings you just entered.

See your industrial network administrator for these settings.
Valid values for DH+ Network Address: 0 – 63

These are the default settings.
Use these settings for Port 2:
• Serial Protocol = Modbus ASCII
• BridgePort Address= 0
• Baud Rate: 9600
• Data Bits: 7
• Retries: 2
• Parity: Even
• RTS Control: None (unavailable)
• Port Type: RS485 2-wire
• Response Time-Out: 125 ms (recommended)
• Maximum Gap Time: 200 (recommended)
• Min Time Between Msgs: 0
• Use Termination: unchecked

These are the default settings.
Use these settings for Port 3:
• Serial Protocol = Modbus ASCII
• Baud Rate: 9600
• Data Bits: 8
• Parity: None
• RTS Control: None
• Maximum Gap Time: 200
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Download the project settings to the BridgePort

15. After you have completed making changes to the project settings, push the Configuration button on the 
BridgePort, shown as Item “F” on page 2.

16. Download the project settings to the BridgePort by selecting Transfer > Download project and follow the 
prompts, as shown here. 

NOTE: After the download is complete, the BridgePort will go into normal run mode. 

Troubleshooting BridgePort modes

There are three options to remove the BridgePort from configuration mode and put it back into normal run 
mode:

1. Download the project to the BridgePort (See “Download the project settings to the BridgePort” above.)

2. Upload the project from the BridgePort to the PLC. (Transfer > Upload project.)

3. Cycle the power to the BridgePort off and on again.

Program messages into the ALPHA sign

Using Adaptive’s Gateway Messaging Software, program messages and variables into any ALPHA signs in 
your network. Refer to “Related documents” on page 1.
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PLC setup instructions

To help you understand how to program a PLC and how it works with the BridgePort and ALPHA signs, this 
section and the pages that follow cover the basics of 5 different messaging functions. These basic examples are 
included in the numbered list, below, which also corresponds to the left-most column, “functions”, in the table at 
the bottom of this page.

NOTE: Use RSLogix 500 software for this setup.

NOTE: You must set up the I/O configuration according to your installation and environment prior to 
setting up the ladder logic program.

These examples illustrate the following basic messaging functions:

1. Write data to an ALPHA sign in a network…

a. to activate a message stored in a sign (as described in “Activate a message stored in a sign.” on page 8)

b. to de-activate a message currently running on a sign

c. to send a variable value to update a message currently running on a sign.

2. Determine which messages are currently running on a sign.

3. Process prior message instructions.

4. Activate a message on all signs in a network.

5. Clear all messages currently running on a sign.

NOTE: PLC element locations can be varied according to your needs; however, sign register numbers 
must be exactly as stated above. (See “How data is stored in ALPHA signs” on page 18 for better 
understanding of sign register numbers.)

NOTE: For additional information on setting up a multi-sign network refer to ““Messaging options and 
individual sign addresses” on page 10. 

Table 1: Important data for the examples

Function

For
more
info–

See
Page :

Location of 
elements in

the PLC table

Address of 
BridgePort 
on the PLC 

network

Address of 
the sign

on the sign
network

Sign’s 
register 
number

Valid values 
for sign 

commands

Direction of 
data flow

Activate a message stored in a sign . . . . . . . . 8 N7:80 10 20 101 1 - 4000 (dec)
4095 (dec)

PLC to sign

De-activate a message currently 
running on a sign  . . . . . . . . . . . . . . . . . . . . 11

N7:81 10 20 102 1 - 4000 (dec)
4095 (dec)

PLC to sign

Send a variable value to update a 
message currently running on a sign. . . . . . 12

N7:82 10 20 1 1 - 100 (dec) PLC to sign

Read a message currently 
running on a sign  . . . . . . . . . . . . . . . . . . . . 14

N7:83 10 20 103 1 - 4000 (dec)
4095 (dec)

Sign to PLC

Process prior message instructions. . . . . . . 15 –– –– –– –– –– ––

Activate a message on all 
signs in a network . . . . . . . . . . . . . . . . . . . . 16

N7:84 10 255 101 1 - 4000 (dec)
4095 (dec)

PLC to sign

Clear all messages currently 
running on a sign  . . . . . . . . . . . . . . . . . . . . 17

N7:85 10 20 102 FFFF (hex)
65,535 (dec)

PLC to sign
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Activate a message stored in a sign.

The number of the message that we want to activate (turn on) in the sign is located at N7:80 in the PLC data 
table. This data must be stored in register number 101 of sign 20.

1. Set up a message instruction in the ladder logic.

NOTE: See the table below this ladder logic diagram for explanations of its parameters.

2. Click on Setup Screen in the message instruction shown above to access a window to set up the parameters 
for this specific instruction. 

Name Description Notes

Type Will always be Peer-To-Peer.

Read/Write
Function to be performed.
Read: Reads data from a sign through the BridgePort.
Write: Sends a message through the BridgePort to a sign.

Target Device Type of device for the Read or Write function. Always use PLC5 for the BridgePort.

Local/Remote
Local: Interfaces directly to a BridgePort.
Remote: Interfaces to a BridgePort through another device.

Control Block

Consists of two parameters – the integer file to use and the starting element in that 
integer file:
Integer File: A block of data elements that the PLC reserves for message instructions, 
N7 in this example.
Starting Element: The number of the element in the integer file where the reserved 
block starts.

The Control Block together with Control Block 
Length are used to reserve elements in the integer 
file for this message instruction. Use caution when 
determining these numbers: reserving a block does 
not prevent any application or instruction from 
writing over data for another application or 
instruction.

Control Block Length
The number of elements that will be used for the string of data. Set by the processor. 
Will always be a fixed block based on the specific type of PLC. In this case, it will be 
14  to communicate with the BridgePort.

Setup Screen Double-click to access a window to set up the parameters for the specific message. See Step 2.

Read/Write Message
Type Peer-To-Peer
Read/Write Write
Target Device PLC5
Local/Remote Local
Control Block N7:0
Control Block Length 14

Setup Screen

0001

MSG

EN

DN

ER

NOTE: When B3:0 is true (= 1), the message instruction in 
this rung (0001) will be executed at the end of the scan, or 
with a SVC instruction (page 15).

B3:0

1

Click this in Step 2.



9

3. Set up the message parameters. 

NOTE: The two main fields in the table, below (“This Controller”, and “Target Device”) correspond to the 
fields for message parameters in the screen shot: 

Name Description Notes

This Controller PLC settings that affect message parameters:

Communication 
Command

Target device and type of instruction (for reference)

Data Table 
Address

Consists of two parameters – the integer file to use and the element number in 
that integer file:
Integer File: A block of data elements that the PLC reserves, N7 in this example.
Element Number: The number of the element in the integer file which contains the 
data to specify which message in the sign to use.

The Data Table Address together with Size in Elements 
are used to set the location of the storage of the data 
(message number, value of a variable, or a value to 
cause the sign to clear the message queue.)
NOTE: Use caution when determining these numbers: 
reserving an address does not prevent any application 
or instruction from writing over data for another 
application or instruction.
Range of valid data for Size in Elements: 1

Size in Elements
Number of elements of data to be passed to a sign.
Always use 1. (The BridgePort only processes one element at a time.)

Channel
The port to be used for transmission.
Generally, Channel 1 is for Data Highway Plus in local mode.

Target Device Settings for BridgePort network “host” device that affect messaging parameters:

Message Timeout Number of scans (retries)

Data Table 
Address

Consists of three parameters:
• N: Denotes an integer file.
• Sign address: 100 plus the sign’s address (displayed by the sign when it starts.)
• Register number: The register number in the sign to be used for the specific 

processing. (See “How data is stored in ALPHA signs” on page 18.)

Range of valid data:
Sign address: 101 - 355
(001 - 255 as interpreted by the sign)
Register number: 1 - 167

NOTE: The error control bit (ER) is set when you are 
using address 355 to transmit to all signs but 
no sign on the network has been individually 
assigned address 255. See “Messaging 
options and individual sign addresses”.

Local Node Addr
(dec/octal)

The specific address (node) of the specific BridgePort on the channel, set in either 
decimal or octal. (See “Set up ALPHA sign communication (Port 2)” on page 5.) 
When decimal is set, octal changes automatically, and when octal is set, decimal 
changes automatically.

Range of valid data:
Decimal: 0 - 63
Octal: 0 - 77

Local/Remote
Automatically set when setting up the message instruction. This is based on the 
setting for the message for this rung of the ladder logic. Shown here for reference.

Element 80 of table N7 
contains the data to 
specify which message 
in the sign to activate.

Accesses register #101 
of sign 20 (120 - 100) 
to specify the message 
to activate in that sign.

N
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Messaging options and individual sign addresses

You can use “address 355” in the messaging instructions to send a “broadcast” message to every one of the 
signs on your network. (See “Activate a message on all signs in a network” on page 16.) 

However, Modbus ASCII protocol uses ‘query and response’ for every exchange of data. If no sign on your 
network has been assigned an individual address as the sign at “address 255”, to provide the proper response to 
messaging instruction “355” (100 + 255), an error code is generated by “broadcast” messages. 

• If your network is set up so that you have no particular need to avoid extraneous, incidental error codes, 
you can use the “address 355” broadcast messaging option. Message transmission and display remain 
unaffected whether or not a ‘response’ is generated from the sign network.

• If you must avoid error bits and at the same time have a need to maintain dedicated, individual 
communication with each one of your signs, (because each sign location can not appropriately display 
messages intended for all other locations, every time) assign multiple addresses for each messaging 
command.

• To avoid error bits you can:

Select one sign to be the target for messages that will be displayed on the entire network. Set 
only that sign’s address to “255” so that it can provide the proper query response (100 + 255). All 
other signs on the network can then be assigned addresses from the valid range 1-254.

NOTE: If you ever need to send a message to that particular sign and that sign, only; you will 
need to change the sign’s address prior to message transmission. The phsical accessibility of the 
sign addressed as “255” should be taken into account if this addressing option is used.

Refer to the section on “Using the Remote Control” near the end of your Gateway Messaging 
Software manual for an explanation of how a handheld remote keypad can be used to quickly 
change a sign’s serial address. (Note–not all Gateway-compatible signs accept infrared 
commands.)
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De-activate a message stored in a sign.

The number of the message that we want to de-activate (turn off) in the sign is located at N7:81 in the PLC data 
table. This data must be stored in register number 102 of sign 20.

1. Set up a message instruction in the ladder logic.

2. Click on Setup Screen in the message instruction shown above.

3. Set up the message parameters.

Read/Write Message
Type Peer-To-Peer
Read/Write Write
Target Device PLC5
Local/Remote Local
Control Block N7:14
Control Block Length 14

Setup Screen

0003

MSG

1
EN

DN

ER

B3:0

Element 81 of table 
N7 contains the data 
to specify which 
message in the sign 
to de-activate.

Accesses register #102 
of sign 20 (120 - 100) 
to specify the message 
to de-activate in that 
sign.
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Send a variable value to update a message currently running on a sign

The value of the variable data that we want to send to sign 20 is located at N7:82 in the PLC data table. This 
data may be stored in any register number of the sign as needed from 1 to 100, which is the range of registers 
reserved for variable data. We’ll store it in register #1, as determined in Step 1 below.

1. Determine the variable register number using Gateway Messaging Software if you don’t already know it. 
(Refer to the Gateway Messaging Software User Manual, P/N 9703-7004, for more information on using 
the software.)

2. Set up a message instruction in the ladder logic to send the value of a variable to update a message in the 
sign.

3. Click on Setup Screen in the message instruction shown above.

B. Click on Insert Variable.

C. Using the scrolling arrows for the 
Variable Number, scroll through the list 
of variables available until you locate the 
correct one. In this case, for Vat2-temp, 
it is Variable Number 1, therefore the 
register number is 1.

A. Find the message with the variable, 
Vat2-temp in this example.

Read/Write Message
Type Peer-To-Peer
Read/Write Write
Target Device PLC5
Local/Remote Local
Control Block N7:28
Control Block Length 14

Setup Screen

0003

MSG

1
EN

DN

ER

B3:0
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4. Set up the message parameters.

Element 82 of table N7 
contains the data to 
specify the value of the 
variable.

Accesses register #1 of 
sign 20 (120 - 100). 
Register #1 is for the 
variable we want to 
update.
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Read a message currently running on a sign

We want to determine the number of the message that’s first (if any) in the message queue for currently-
running messages in sign 20. The message queue consists of the sign’s register numbers 103 to 167. The data for the 
first message in the message queue is located in register number 103. We’ll store the number of the sign’s first 
message at N7:83 in the PLC data table.

1. Set up a message instruction in the ladder logic.

2. Click on Setup Screen in the message instruction shown above.

3. Set up the message parameters.

4. To read other messages in the message queue, specify the desired register number in the sign – any 
number from 103 to 167. Be sure to store the results at different element locations in the PLC data table.

0004

Read/Write Message
Type Peer-To-Peer
Read/Write Read
Target Device PLC5
Local/Remote Local
Control Block N7:42
Control Block Length 14

Setup Screen

MSG

EN

DN

ER

B3:0

1

Element 83 of table N7 
contains the data to 
specify which message 
in the sign we’ve read.

Accesses register #103 
of sign 20 (120 - 100) 
to specify the message 
number that’s running.
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Process prior message instructions

1. (Optional: If you are using multiple message instructions in your program, you may need to use the SVC 
Instruction to properly transmit the message instructions.) Set the SVC channel: There is a maximum of 4 
message instructions which can be active at the same time, although more can be available in the ladder 
logic file. Therefore, to process any set of message instructions (up to 4), the Service Communications 
instruction is set up, as shown here. This will stop the PLC scan processing, send instructions, and then 
resume processing.

Name Description

Channel 0 May be set as needed for other applications.

Channel 1 The Data Highway Plus channel. Set to Yes.

Service Communications
Channel 0 No
Channel 1 Yes

0006

SVC
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Activate a message on all signs in a network

Here, we want to activate a specific message that is stored on all signs in the sign network. The number of the 
message to activate is located at N7:84 in the PLC data table. This data must be stored in register number 101 of all 
signs. The way to designate “all signs” is to specify “255” for the sign address. This will be received and calculated 
by each sign as “255 + 100” or “355”. Designating sign address “355” is interpreted to mean “all signs”, and 
therefore, the message will be activated on all signs. (This is also referred to as sending a “broadcast” message.)

1. Set up a message instruction in the ladder logic.

2. Click on Setup Screen in the message instruction shown above.

3. Set up the message parameters. 

NOTE: The error control bit (ER) is set when you are using messaging instruction “address 355” to 
transmit a “broadcast message” to all signs but no sign on the network has been individually 
assigned address 255 (100 + 255 = 355). See “Messaging options and individual sign addresses” on 
page 10.

0005

Read/Write Message
Type Peer-To-Peer
Read/Write Write
Target Device PLC5
Local/Remote Local
Control Block N7:56
Control Block Length 14

Setup Screen

MSG

EN

DN

ER

B3:0

1

Element 84 of table N7 
contains the data to 
specify which message 
in the signs to activate.

Accesses register #101 
of sign 355 (100 + 255) 
to specify the message 
to activate in all signs.
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Clear all messages currently running on a sign

We want to clear (de-activate) all active messages in sign 20. The way to do this is to send “FFFF” hexadecimal 
(“65535” decimal) to the sign. This value is located at N7:85 in the PLC data table. This data must be stored in 
register number 102 of the sign. “FFFF” hexadecimal is interpreted by the sign to mean “all messages”.

1. Set up a message instruction in the ladder logic.

2. Click on Setup Screen in the message instruction shown above.

3. Set up the message parameters.

Read/Write Message
Type Peer-To-Peer
Read/Write Write
Target Device PLC5
Local/Remote Local
Control Block N7:70
Control Block Length 14

Setup Screen

0003

MSG

EN

DN

ER

B3:0

1

Element 85 of table N7 
contains the data 
(“FFFF” hex) to specify 
for the signs.

Sends the data to 
clear (de-activate) all 
messages on sign 20 
(120 - 100)
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How data is stored in ALPHA signs

The illustration below represents the type of information stored in each sign.

Safety and troubleshooting

When successfully connected to a Data Highway Plus industrial network, there should always be some type of 
message on each ALPHA sign connected to this network.

PROBLEM:
No message appears

on ALPHA sign
“No Network Activity”

message appears on ALPHA sign
“NO BACKGROUND MESSAGE”1

 appears on ALPHA sign

POSSIBLE CAUSE:

• Network wiring fault
• PLC fault
• BridgePort fault
• ALPHA sign fault (possible sign 

hardware failure or a PLC is trying 
to display a message that was not 
programmed into the sign)

• Message(s) too long for preset file 
size

• Sign not plugged in or turned on

• Network wiring fault
• PLC fault
• BridgePort fault
• ALPHA sign fault
• ALPHA sign timeout because there 

was no network activity for at least 3 
seconds

• Sign address not correct.
• The sign has not received any 

message to display. (This is not an 
error condition.)

• Sign is receiving information, but 
the information is not for this sign. 
(This is not an error condition.)

1 This is called the “background message”. The Gateway Messaging Software can be used to change the wording of this message.

Register #

1
2
3
.
.
.
100
101
102
103
.
.
.
167

Description

Variable #1 (+ or - integer value)
Variable #2 (+ or - integer value)
Variable #3  (+ or - integer value)
.
.
.
Variable #100  (+ or - integer value)
Message Activation Register (the Message # to turn on)
Message De-activation Register (the Message # to turn off)
First message
Second message
Third message
.
.

Message #

1
2
3
.
.
.
2000

Description

Message #1 (100-characters)
Message #2 (100-characters)
Message #3 (100-characters) 
.
.
.
Message #2000 (100-characters)

How messages and variables are stored inside ALPHA signs

Variable & Message storage

( with Gateway firmware)
ALPHA sign

Queue of messages
running in the sign


	Introduction
	Related documents
	BridgePort description
	BridgePort interconnection diagram
	BridgePort setup instructions
	Troubleshooting BridgePort modes
	Program messages into the ALPHA sign
	PLC setup instructions
	How data is stored in ALPHA signs
	Safety and troubleshooting

