ADArI TI\/E How to connect ALPHA signs to Modbus Plus

using the MD3000

Introduction

This document explains how to set up the MD3000 to act as an interface between a Modbus Plus industrial
network and an ALPHA sign network (as illustrated below):

Motors, switches, PLC Modbus Plus Gateway RS485 Al PHA siq
relays, etc. industrial network | (MD3000) Jatewsa
Master mode Slave mode
INFORMATION FLOW

L

NOTE: In the event of a communication failure, caused by any means, messages may not be displayed on a
sign.

Specifically, this document describes how to:
¢ connect the MD3000 to a Modbus Plus PLC
¢ connect the MD3000 to one or more ALPHA signs

use the MD3000 Configuration Editor software to set up the MD3000 so that it interfaces between a
Modbus Plus PLC and an ALPHA sign network.

Related documents

Document name Part number Description
Gateway Messaging Software User Manual 9703-7004A Describes how tQ use Adapt'lves Gateway Messaging Software to
store messages in ALPHA signs.
Network Configurations 9708-8046A Explains how to network ALPHA signs.

Revision date: 2/29/00 Copyright © 1999-2000 Adaptive Micro Systems, Inc.

9703-7005C
The distinctive Trade Dress of this product is a trademark claimed by Adaptive Micro Systems, Inc.



MD3000 description

The MD3000 is an intelligent Modbus Plus-to-serial communications interface unit. It allows data exchange
between a Modbus Plus host and ALPHA signs equipped with the Gateway firmware option.

Operating modes

Using the MD3000’s DIP switches, the unit can be set to either one of two types of operation: Normal
Operation Mode or Configuration Mode:

®  Normal Operation Mode (DIP switch settings: 1, 2, 3, 4 = OFF) — In this mode, Ports 1, 2, and 3 are all active.
The MD3000 will first wait for configuration from the Modbus Plus host before initiating with the ALPHA
sign(s).

e Configuration Mode (DIP switch settings: 1, 2, 4 = OFF; 3 = ON) — In this mode, only Port 3 is active. Ports 1
and 2 are not active. This mode is used to set up the various MD3000 parameters (e.g., baud rate, PLC
address, etc.) with the MD3000 Configuration Editor software.
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view MD 3000 view
ltem Name Description
A Port 3 LED Green = trqn_smlttmg data
Red = receiving data
B STATUS LED Flashing green = unit initialized OK and is in Configuration Mode.

Flashing red = Modbus Plus error

Use these switches to set the operating mode of the unit:
C DIP switches Normal Operation Mode (used to relay PLC data to ALPHA signs): 1, 2, 3, 4 = OFF.
Configuration Mode (used to program the MD3000): 1, 2, 4 = OFF; 3= 0N

Continuous Flash = Modbus Plus Communications OK.
D Port 1 LED 3 Flashes then Pause = No other Nodes on Network.
4 Flashes then Pause = Duplicate Node Numbers on Network.

Connect to a personal computer that is running the MD3000 Configuration Editor software

E Port 3 ("passthrough port’) and the Gateway Messaging Software.

F Power connector Connect to a DC power supply of 7 to 28 volts rated at 9 watts.
G Port 1 Data input from a Modbus Plus host.
H Port 2 Data output to one or more ALPHA signs.

Green = transmitting data

: Port2 LED Red = receiving data




MD3000 interconnection diagram
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( running MD3000 Configuration Editor software )

Port 3
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ALPHA sign PLC

( with Gateway firmware)
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( with Gateway firmware )
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to next sign

ltem Part # Description

DBY-to-DB25 Configuration Cable to Port 3

A | 1188-0005

Computer

DB9 Female
(RS485)
TXDO03

MD3000
DB25 Male
(RS485)
03 RXD

RXD 02
GND 05

02 TXD
07 GND

RTS 07
CTS 08

DCD 01
DTR 04 3
DSR 06

Modbus Plus cable to Port 1

MD3000
DB9 Male

03 V-

02 CAN_L
05 Shield
07 CAN_H
09 V+




DB25-to-3-wire cable to Port 2:

to sign

to Modular
1188-9101 Nellwork Adapler MD3000
Stripped wires DB25 Male For MD3000 units with revision F
BK YL (RS485)  prve o, (224?5) or earlier, terminating resistors
+ WHITE | 2 Rii are plrovilded wi?hin thg unit. Other
- WIRE r 21 Tx- terminating resistors in the
v L ore system must be removed.
Modular KV 01 SHIELD
Network 04 RTS For MD3000 units with revision G
Adapter [ oscrs or later, jumpers 9-10 and/or 11-
?g 12 must be clipped if terminating
11 resistors are elsewhere in the
12 system.

1088-8000 | RS485 cable

4331-0602 Modular Network Adapter (NOTE: On some ALPHA signs, this adapter is inside the sign.)

1088-8636 1 foot, 4-conductor RS485 cable (NOTE: If the Modular Network Adapter is inside the ALPHA sign, this cable is not necessary.)

D) M| m| O

1088-9105A | DB25-to-DB9 adapter (for DB25 computer COM port)




MD3000 Setup Instructions for the Gateway in the Slave Mode

1. Attach a personal computer to the MD3000. (See “MD3000 interconnection diagram” on page 3.)
2. Put the MD3000 into Configuration Mode by setting DIP switch 3 to the ON position.

3. If not already installed, install the MD3000 Configuration Editor DOS software on the personal computer
that will be used to program the MD3000.

Project file creation

4. Start the MD3000 Configuration Editor software. A screen similar to the following will appear.

& moslo - EDITOR [_ ol ]
[ aue - & E@IIE&I

Information

Close box

Mailing Address

Shipping Address

5. Create a new file by selecting Project > New.

Enter a name for the new project file

Select Modbus+ Master(s) to PLCs or Devices
for Project type by double clicking on the field.

6. Click Ok and then save the project by selecting Project > Save.

COM port setup

7. Select Options > Set COM Port and choose the PC COM Port you will use to communicate with the
MD3000. (The default is COM 1.)

inications FPort

8. Select Save. You will be notified that the information was saved. Click Ok to exit this screen.

9. (Optional) Once a COM Port is selected, you may wish to save this setting by selecting Options > Default
Options. If you do not do this, the COM port setting may revert to a former setting. The COM port setting
is not part of the project, so saving the project will not save the COM port setting.



PLC communication (Port 1) setup
10. Select Edit > Port 1 (Modbus+ Master) to set up Port 1 on the MD3000.

[M]=——= Port 1 [(Modbus Plus V

See your industrial

: network administrator
- . for the Moabus Plus
Address of MD3000.

Modbus Plus Node Addr

11. Select the Modbus Plus Node Address of MD3000. (See your network administrator for the correct address.)

12. Select Save. You will be notified that the information was saved. Click Ok to exit this screen.

ALPHA sign communication (Port 2) setup

13. Select Edit > Port 2 (Slave PLCs) to set up the MD3000 so that it can communicate with ALPHA signs
equipped with the Gateway firmware option.

14. Click once in the field for PLC/Device Protocol, use the scroll bar and select Modbus ASCII by double clicking
on it. Also select 2-wire RS422 or RS 485 Communications by clicking in the box.

= pl:ll_'t. 2
Use these settings for Port 2: LC ice Protocol:
PLC/Device Protocol= Modbus ASCII
Communications. 2-wire RS422 or RS485
MD3000 Address. 0
Baud Rate: 9600
Data Bits: 7
Parity. Even
Stop Bits: 2
RTS Control: None
Response Time-Out. 500 ms (recommended)

Hodbus

15. Save the settings for Port 2. You will be notified that the information was saved. Click Ok to exit this
screen.

“Passthrough” (port 3) setup
16. Select Edit > Port 3 (Passthrough) to set up Port 3.

ssthrough) Configuration

These are the default settings.
Use these settings for Port 3. [ ] 2-wire B242Z or RBS485 Communications
e Communications. Leave unchecked
for RS232

Baud Rate: 9600 . . t i pearers
Data Bits: 8 { ) BTS Delay
Parity. None

Stop Bits: 1

RTS Control: None
Intermessage Time-Out. 100 ms




17. Save the settings for Port 3. You will be notified that the information was saved. Click Ok to exit this
screen.

Downloading the project settings to the MD3000

18. If you haven't already done so, put the MD3000 into Normal Operating Mode by setting all DIP switches
to the OFF position.

19. After you have completed making changes to the setup parameters, download the project settings to the
MD3000 by selecting Transfer > Download project to MD3000 and follow the prompts, such as shown here.

Confirm

Safety and troubleshooting

When successfully connected to a Modbus Plus industrial network, there should always be some type of
message on each ALPHA sign connected to this network:

“ FArTa) « «l
PROBLEM: | No message appears on ALPHA sign No Network Activity” message NO BACKGROUND MESSAGE

appears on ALPHA sign appears on ALPHA sign
o Network wiring fault . Network wiring fault o Sign address not
¢ PLC fault «  PLC fault correct.
«  MD3000 fault «  MD3000 fault * The ?'93 has not t
) ) ) received any message to
et ovcodll I il (s
. e ALPHA sign timeout error condition).
Possible Cause: PLC is trying to display a because tﬁere was . o )
message that was not no network activity ) §|gn IS receiving
programmed into the sign). for at least 3 information, but the
information is not for
. Message(s) too long for the seconds

this sign.
preset ffile size 0

o Sign not plugged in

" This is called the “background message”. The Gateway Messaging Software can be used to change the wording of this message.




Messaging example

To help you understand how to program the MD3000 and how it works with a PLC and ALPHA signs, a
complete messaging example follows.

The big picture

How to get PLCs to communicate with ALPHA signs

What How

Program Gateway device Gateway device (e.g., Modbus Plus) software
1. (Map messages and variables (different for each manufacturer)

to one or more ALPHA signs)
9 Create messages and variables Gateway Messaging Software

) and store them in ALPHA sign(s)  (created by Adaptive)

Program the PLC PLC software

3 (associate maching “actions” (different for each manufacturer)

with the messages and variables
created in Step 1 above)

The example
Here’s the situation:

¢ In this example factory, there’s a conveyor belt and an automated lathe connected to a Modbus Plus PLC
(whose address = 5). This PLC is connected to a MD3000 (whose address = 3) and to two ALPHA signs
(whose addresses are 7 and 8).

NOTE: Sample PLC register addresses are used below.

*  Onthe ALPHA sign with address = 7, you want to display messages about the conveyor belt: Conveyor Belt
Speed = [a number representing the belt speed], Conveyor Belt Off, and Motor Overload.

® Onthe ALPHA sign with address = 8, you want to display messages about the automated lathe: Lathe On
and Lathe Off.



These are the steps to follow for this example:

1. Using the Gateway Messaging Software, program the messages — and the one variable — into each of
the two ALPHA signs. The illustration below represents the type of information stored in each sign:

How messages and variables are stored inside ALPHA signs

" ALPHA sign ‘|

( with Gateway DP firmware)

e Message #1 = Conveyor Belt On: Speed =
[the speed is contained in Variable #1]

o Message #4 = Conveyor Belt Off

e Variable #1 = conveyor belt speed

Variable & Message storage

‘ For the ALPHA sign with address = 7:

Register # | Description

1 Variable #1 (+ or - integer value) o Message #5 = Motor Overload
2 Variable #2 (+ or - integer value)
8 Variable #3 (+ or - integer value) For the ALPHA sign with address = 8:

® Message #2 = Lathe On

-100 i/ariable #100 (+ or - integer value) * Message #3 = Lathe Off

101 Message Activation Register (the Message # to turn on)
102 Message Deactivation Register (the Message # to turn off)
103 Message queue

167

Message #| Description

1 Message #1 (100-characters)
2 Message #2 (100-characters)
3 Message #3 (100-characters)
2000 Message #2000 (100-characters)

2. Using the software that came with it, program the Modbus Plus PLC that will be sending information to
the MD3000.

3. Using the MD3000 Configuration Editor software, program the MD3000.
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The complete setup for the PLC, MD3000, and ALPHA signs looks like th

4.
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