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How to connect ALPHA signs to DeviceNet
using the DN3000

Introduction

This document explains how to set up the DN3000 to act as an interface between a DeviceNet industrial
network and an ALPHA sign network (as illustrated below).

Motors, switches,
relays, etc.

PLC
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NOTE: In the event of a communication failure, caused by any means, messages may not be displayed on a

sign.

Specifically, this document describes how to:

¢ connect the DN3000 to a DeviceNet PLC
¢ connect the DN3000 to one or more ALPHA signs

* use the DN3000 Configuration Editor software to set up the DN3000 so that it interfaces between a
DeviceNet PLC and an ALPHA sign network.

Related documents

Document name Part number Description
) 9703-7004 Describes how to use Adaptive's Gateway Messaging
Gateway Messaging Software User Manual Software to store messages in ALPHA signs.
Network Configurations 9708-8046A Explains how to network ALPHA signs.
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DN3000 description

The DN3000 is an intelligent DeviceNet-to-serial communication interface unit. It allows data exchange
between a DeviceNet host and ALPHA signs equipped with the Gateway firmware option.

Operating modes

Using the DN3000’s DIP switches, the unit can be set to either one of two types of operation: Normal
Operation Mode or Configuration Mode.

®  Normal Operation Mode (DIP switch settings: 1, 2, 3, 4 = OFF) - In this mode, Ports 1,2, and 3 are all active.
The DN3000 will first wait for configuration from the DeviceNet host before initiating with the ALPHA
signs(s).

e Configuration Mode (DIP switch settings: 1, 2, 4, = OFF; 3 = ON) - In this mode, only Port 3 is active. Ports 1
and 2 are not active. This mode is used to set up the various DN3000 parameters (e.g., baud rate, PLC
address, etc.) with the DN 3000 Configuration Editor software.

H
Front DeviceNet
view D'!Ef?.goo
ltem Name Description
A Port 3 LED Green = transmitting data

Red = receiving data

Flashing green = unit initialized OK and is in Configuration Mode.

B STATUS LED Flashing red = DeviceNet error.

Use these switches to set the operating mode of the unit:
C DIP switches Normal Operation Mode (used to relay PLC data to ALPHA signs): 1, 2, 3, 4 = OFF.
Configuration Mode (used to program the DN3000): 1, 2, 4 = OFF; 3=0N

Left LED Right LED

0ff=No Power Off = Not Powered/Not Online

Flashing Green = Device in Standby Flashing Green = Online, Not Connected

Green = Device Operational Green = Link OK, Online, Connected

D Port 1 LED Flashing Red = Minor Fault Flashing Red One or more /0 Connections

Red = Unrecoverable Fault are in the Timed-Out state

Flashing Red-Green = Device Self Testing Red = Critical Link Failure (Duplicate MAC ID
or Bus-off)
Flashing Red-Green = Device Self Testing

Connect to a personal computer that is running the DN3000 Configuration Editor software

E Port 3 ("passthrough port’) and the Gateway Messaging Software.

F Power connector Connect to a DC power supply of 7 to 28 volts rated at 9 watts.
G Port 1 Data input from a DeviceNet host.

H Port 2 Data output to one or more ALPHA signs.

I Port 2 LED Green = transmitting data

Red = receiving data




DN 3000 interconnection diagram
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Personal computer
| ( running DN3000 Configuration Editor software )

Port 2

ALPHA sign

( with Gateway firmware)

ALPHA sign

( with Gateway firmware )

RS232 /l/

to next sign

Port 3

PLC

Item Part #

Description

A | 1188-0005

DBY-to-DB25 Configuration Cable to Port 3

Computer

DB9 Female
(RS485)
TXD03

RXD 02

DN3000
DB25 Male
(RS485)
03 RXD

GND 05

02 TXD
07 GND

RTS 07
CTS 08 :l

DCD 01
DTR 04 3
DSR 06

DeviceNet cable to Port 1

DN3000
DB9 Male

03 V-

02 CAN_L
05 Shield
07 CAN_H
09 V+




DB25-to-3-wire cable to Port 2

to sign

to Modular
Network Adapter DN3000
ety Stripped wires DB25 Male For DN3000 units with revision F
| YL (RS40)  mwe -, (Z§4T85) or earlier, terminating resistors
+ ware 4 b L_oa Rf(: are provided within the unit. Other
_ L 21 Tx- terminating resistors in the
1 |_ 22 Rx- system must be removed.
Modular N 01 SHIELD
Network E 04 RTS For DN3000 units with revision G
Adapter 05CTS or later, jumpers 9-10 and/or 11-
?g 12 must be clipped if terminating
11 resistors are elsewhere in the
12 system.

1088-8000 | RS485 cable

4331-0602 Modular Network Adapter (NOTE: On some ALPHA signs, this adapter is inside the sign.)

1088-8636 1 foot, 4-conductor RS485 cable (NOTE: If the Modular Network Adapter is inside the ALPHA sign, this cable is not necessary.)

D M| m| O

1088-9105A | DB25-to-DBY adapter (for DB25 computer COM port)




DN3000 setup instructions

1. Attach a personal computer to the DN3000. (See “DN 3000 interconnection diagram” on page 3.)
2. Put the DN3000 into Configuration Mode by setting DIP switch 3 to the ON position.

3. If not already installed, install the DN3000 Configuration Editor DOS software on the personal computer
that will be used to program the DN3000.

Project file creation

4. Start the DN3000 Configuration Editor software. A screen similar to the following will appear.

& moslo - EDITOR [_ ol ]

Information
Close box

Mailing Address

Shipping Address

5. Create a new “project” file by selecting Project > New:

HINT: You can ’7[.] ———— HNew Project
als_o _choose- an Enter a name for the new project file Project Name: JPBOITOT
existing project by -

double clicking on
the project name
shown to get a
drop-down list.

Select DeviceNet to PLCS or Devices
for Project Type.

6. Click Ok and then save the project by selecting Project > Save.

COM port setup
7. Select Options > Set COM Port and choose the PC Com Port you will use to communicate with the DN3000.
(The default is COM 1.)

8. Select Save. You will be notified that the information was saved. Click Ok to exit this screen.

9. (Optional) Once a COM Port is selected, you may wish to save this setting by selecting Options > Default
Options. If you do not do this, the COM port setting may revert to a former setting. The COM port setting
is not part of the project, so saving the project will not save the COM port setting.



PLC communication (Port 1) setup
10. Select Edit > Port 1 (DeviceNet) to set up Port 1 on the DN3000.

[il—— Port 1 <(DeviceHNet>
[ﬂnc ID of DN3B@A: N2 " This is a number from 0 to 63

which is a DeviceNet unique
MAC ID address. See your
industrial network administrator
for the MAC ID of DN3000.

Select the baud rate used
by your DeviceNet network.

11. Select Save. You will be notified that the information was saved. Click Ok to exit this screen.

ALPHA sign communication (Port 2) setup

12. Select Edit > Port 2 (PLCs/Devices) to set up the DN3000 so that it can communicate with ALPHA signs
equipped with the Gateway firmware option:

[¥] 2-wire - ommunications

Use these settings for Port 2:

PLC/Device Protocol: Modbus ASCII
Communications: 2-wire RS422 or RS485
DN3000 Address: 0

Baud Rate: 9600

Data Bits: 7

Parity. Even

Stop Bits: 2

RTS Control: None

Response Time-Out. 500 ms (recommended)

13. Save the settings for Port 2. You will be notified that the information was saved. Click Ok to exit this
screen.

“Passthrough” port (Port 3) setup
14. Select Edit > Port 3 (Passthrough) to set up Port 3.

W[ 1 Port 3 (Passthrough? Configuration

[ 1 2-wire RS422 or RS485 Communications

Use these settings for Port 3:

o Passthrough to: Port 2 (Modbus ASCII)
e Communications. Leave unchecked for
RS232

Baud Rate: 9600

Data Bits: 8

Parity. None

Stop Bits: 1

RTS Contro: None

Intermessage Time-Out. 100 ms

15. Select Save. You will be notified that the information was saved. Click Ok to exit this screen.



ALPHA sign register setup

16. Select Edit > I/O Configuration window and select Use I/O Data to set up what data the DN3000 will
transmit to the ALPHA signs.

[M]————— I/0 Data Configuration
”: [ 1 Use I/0 Data ”:[ —_—

Check Use 1/0 Data.

Cutput Data H - words (Consumed I/0)

17. Enter the total number of words you will need to use (3 in this example). Select Save.

Cconfiguration

Enter the total
number of
words.

Coutput Ds H | words (Consumed I/0)

Select
Output Data.

output Da Size: |3 i ed I/0)

[=]
Word PLC




19. In the Output Data Table, you can press Return for the specific Word to use, or you can double click on that
line. Then check the box to see the entries for that Word.

To assign a new register, use the arrow keys
or the mouse to move the highlight bar to

an empty space and then press Return. ﬁ
[M] =————= Entry for Cutput Word 1
”; '] Use Output Word 1

Check Use Output Word 1.

Entry for Output Word 1
[¥] Use Qutput Word 1

This screen shows the ALPHA sign address
and one of the sign’s registers of where
information is going to be stored.

20. Here is an example of several settings.

Example Output Data Table settings

e i . In these example settings,
N 2 e ALPHA sign address #2 Register 101 = activation register for
’7 this ALPHA sign.
o ALPHA sign address #2 Register 102 = deactivation register
) for this ALPHA sign.
In this table, e ALPHA sign address #2 Register 1 =a variable value stored
PLC Addresses in this ALPHA sign.
are actually
ALPHA sign
addresses.

21. Select Save for the Output Data Table window to save all the register settings you just entered. Then select
Ok twice.

Check the PC’s communication port

22. Before downloading your project settings to the DN3000, double-check your PC’s COM Port settings. To
do this, select Options > Set Com Port and verify that the Port is correct. Change if necessary, then select Ok.




Download the project settings to the DN3000

23. If you haven't already done so, put the DN3000 into Normal Operating Mode by setting all DIP switches
to the OFF position.

24. After you have completed making changes to the setup parameters, download the project settings to the
DN3000 by selecting Transfer > Download project to DN3000 and follow the prompts, such as shown here.

Confirm




Safety and troubleshooting

When successfully connected to a DeviceNet industrial network, there should always be some type of message

on each ALPHA sign connected to this network:

PROBLEM:

No message appears on ALPHA sign

“No Network Activity” message
appears on ALPHA sign

“NO BACKGROUND MESSAGE”’
appears on ALPHA sign

Possible Cause:

¢ Network wiring fault
e PLC fault
e DN3000 fault

* ALPHA sign fault possible sign
hardware failure or a PLC is trying
to display a message that was not
programmed into the sign.

* Message(s) too long for preset file

e Network wiring fault
e PLC fault

e DN3000 fault

e ALPHA sign fault

e ALPHA sign timeout
because there was no
network activity for at
least 3 seconds

. Sign address not correct.

¢  The sign has not received
any message to display.
(This is not an error
condition).

e Sign is receiving
information, but the
information is not for this
sign.

size
¢ Sign not plugged in or turned on

" This is called the “background message”. The Gateway Messaging Software can be used to change the wording of this message.

Messaging Example

To help you understand how to program the DN3000 and how it works with a PLC and ALPHA signs, a
complete messaging example follows.

The big picture

How to get PLCs to communicate with ALPHA signs

What How

Program Gateway device Gateway device (e.g., DeviceNet) software
1. (Map messages and variables (different for each manufacturer)

to one or more ALPHA signs)
9 Create messages and variables Gateway Messaging Software

) and store them in ALPHA sign(s)  (created by Adaptive)

Program the PLC PLC software

3 (associate machine “actions” (different for each manufacturer)

with the messages and variables
created in Step 1 above)

The example
Here’s the situation:

¢ In this example factory, there’s a conveyor belt and an automated lathe connected to a DeviceNet PLC
(whose address = 5). This PLC is connected to a DN3000 (whose address = 3) and to two ALPHA signs
(whose addresses are 7 and 8).

NOTE: Sample PLC register addresses are used below.

® Onthe ALPHA sign with addresses = 7, you want to display messages about the conveyor belt: Conveyor
Belt Speed = [a number representing the belt speed], Conveyor Belt Off, and Motor Overload.

® Onthe ALPHA sign with address = 8, you want to display messages about the automated lathe: Lathe On
and Lathe Off.

10



These are the steps to follow for this example:

1. Using the DN3000 Configuration Editor software, program the DN3000.

2. Using the Gateway Messaging Software, program the messages - and the one variable - into each of the
two ALPHA signs. The illustration below represents the type of information stored in each sign:

How messages and variables are stored inside ALPHA signs

. ALPHA sign ‘|

( with Gateway DP firmware)

Variable & Message storage

Register #

Description

1
2
3

100
101
102
103

167

Variable #1 (+ or - integer value)
Variable #2 (+ or - integer value)
Variable #3 (+ or - integer value)

Variable #100 (+ or - integer value)

Message Activation Register (the Message # to turn on)
Message Deactivation Register (the Message # to turn off)
Message queue

Message #

Description

Message #1 (100-characters)
Message #2 (100-characters)
Message #3 (100-characters)

Message #2000 (100-characters)

3. Using the software that came with it, program the DeviceNet PLC that will be sending information to the

DN3000.

1
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The complete setup for the PLC, DN3000, and ALPHA signs looks like th:

4.
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